Skip to content

About

A C++ implementation of ping command following RFC 791 and RFC 1071

Resources

Stars

0 stars

Watchers

0 watching

Forks

Latest commit

 

History

5 Commits

Folders and files

NameName
Last commit message
Last commit date
 
 
 
 
 
 
 
 
 
 

Repository files navigation

Custom C++ ICMP Ping

A lightweight, from-scratch implementation of the ping utility in modern C++ using Linux raw sockets (SOCK_RAW). Built in accordance with RFC 792 (ICMP) and RFC 1071 (Internet Checksum).

Current Features and Future enhancements

  • Socket + Single Packet Round Trip
  • Timing + Real Output Formatting
  • Timeout / Packet Loss Handling
  • Continuous Loop + Sequence Tracking
  • Final Stats Output & CLI args
  • Makefile and CLI args

About

A C++ implementation of ping command following RFC 791 and RFC 1071

Resources

Stars

0 stars

Watchers

0 watching

Forks

Releases

Packages

Contributors

Languages