You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
Could the maintainers clarify the supported upgrade path from azure-ai-projects 2.3 to 2.4+ / 2.6 when using the current stable agent-framework-foundry 1.12.0?
Published metadata currently declares:
Distribution
Relevant requirement
agent-framework-foundry==1.12.0
azure-ai-projects>=2.2.0,<2.4.0
agent-framework-openai==1.14.2
openai>=2.25.0,<4
azure-ai-projects==2.6.0
openai>=3.0.0
The OpenAI-major overlap now exists with adapter 1.14.2, but Foundry's independent Projects upper bound still prevents combining the two latest stable Foundry/Projects distributions. This is a dependency-resolution/support question, not a claim that a specific stable Projects API is broken.
The <2.4 bound was introduced before Projects 2.4 was published. I could not find an explicit explanation for retaining it through Foundry 1.12.0.
Questions
Does <2.4 reflect a demonstrated Projects 2.4+ incompatibility, a deliberately validated/support window, or metadata awaiting an update?
If there is a known incompatibility, which APIs/behaviors and tracking issue or regression tests describe it?
Now that the OpenAI adapter supports SDK 3.x, what work remains for Foundry to support Projects 2.6?
Which coherent stable package set do maintainers recommend for applications that need Projects 2.4+ features without overriding dependency constraints or reverting functionality?
Minimal dependency conflict
These requirements cannot be resolved together under the published metadata:
The conflict is azure-ai-projects<2.4.0 versus azure-ai-projects==2.6.0.
No dependency override, --no-deps installation, or live service call is needed to establish that conflict.
We are retaining a locked baseline while investigating candidate upgrades. An older Foundry release's broader bound is not being treated as evidence of support for newer Projects behavior.
Additional bounded evidence: normal uv0.12.7 resolution rejects Foundry1.12.0 + Projects2.6.0 exactly because Projects>=2.2,<2.4 conflicts with==2.6.0. Separately, Python3.13.15 can resolve/install Core1.17.0 + olderFoundry1.10.1 + OpenAIadapter1.14.2 + Projects2.6.0 + OpenAI3.8.0 (HTTPX2 2.12.0), with uv pip check passing. Projects/Foundry client constructors and the safe Harness factory/local session construct offline; this does not exercise remote session creation, Responses, MCP or Azure authentication. We are not treating the older adapter range as support evidence or overriding1.12 bounds. The specific clarification remains: what known behavior or validation/support boundary keeps the current Foundry package capped below2.4, and what is the maintainer-recommended forward path? No production upgrade was made.
Adding a real-world data point that confirms this is a live blocker, not just a theoretical question.
We hit the exact same conflict via Dependabot on a public repo (doruit/forged-with-foundry): Dependabot repeatedly proposed bumping azure-ai-projects to >=2.4.0 while our agent-framework-foundry==1.11.0 pin still required <2.4.0, producing an unresolvable PR every time. We worked around it with an explicit Dependabot ignore rule for azure-ai-projects>=2.4.0 to stop the noise until this is resolved upstream.
Separately, this thread surfaced something worth flagging for anyone reading it who's tempted to bump openai alone once agent-framework-openai gains an openai<4 upper bound (per #7967): doing so is incomplete, not just risky. agent-framework-foundry==1.11.0 (our currently pinned version) still transitively resolves to an agent-framework-openai release with openai<3. Bumping openai to a 3.x release without also bumping agent-framework-foundry to >=1.12.0 produces a package set that either fails to resolve, or (if pip backtracks to a different transitive patch version) installs "successfully" without ever having been exercised by agent-framework-foundry's own test matrix against that combination. A note in this issue (or in agent-framework-foundry's release notes) clarifying the minimum coherent {foundry, openai adapter, projects, openai} version set would help downstream Dependabot configs avoid exactly this trap.
Happy to share our dependabot.yml workaround if useful as a reference.
Activity
arush-saxena commentedon Sep 6, 2026
Additional bounded evidence: normal uv0.12.7 resolution rejects Foundry1.12.0 + Projects2.6.0 exactly because Projects>=2.2,<2.4 conflicts with==2.6.0. Separately, Python3.13.15 can resolve/install Core1.17.0 + olderFoundry1.10.1 + OpenAIadapter1.14.2 + Projects2.6.0 + OpenAI3.8.0 (HTTPX2 2.12.0), with uv pip check passing. Projects/Foundry client constructors and the safe Harness factory/local session construct offline; this does not exercise remote session creation, Responses, MCP or Azure authentication. We are not treating the older adapter range as support evidence or overriding1.12 bounds. The specific clarification remains: what known behavior or validation/support boundary keeps the current Foundry package capped below2.4, and what is the maintainer-recommended forward path? No production upgrade was made.
doruit commentedon Sep 7, 2026
Adding a real-world data point that confirms this is a live blocker, not just a theoretical question.
We hit the exact same conflict via Dependabot on a public repo (
doruit/forged-with-foundry): Dependabot repeatedly proposed bumpingazure-ai-projectsto>=2.4.0while ouragent-framework-foundry==1.11.0pin still required<2.4.0, producing an unresolvable PR every time. We worked around it with an explicit Dependabotignorerule forazure-ai-projects>=2.4.0to stop the noise until this is resolved upstream.Separately, this thread surfaced something worth flagging for anyone reading it who's tempted to bump
openaialone onceagent-framework-openaigains anopenai<4upper bound (per #7967): doing so is incomplete, not just risky.agent-framework-foundry==1.11.0(our currently pinned version) still transitively resolves to anagent-framework-openairelease withopenai<3. Bumpingopenaito a 3.x release without also bumpingagent-framework-foundryto>=1.12.0produces a package set that either fails to resolve, or (if pip backtracks to a different transitive patch version) installs "successfully" without ever having been exercised byagent-framework-foundry's own test matrix against that combination. A note in this issue (or inagent-framework-foundry's release notes) clarifying the minimum coherent{foundry, openai adapter, projects, openai}version set would help downstream Dependabot configs avoid exactly this trap.Happy to share our
dependabot.ymlworkaround if useful as a reference.