Repository navigation
docs: state that Agent Skills and Evaluations from Code need 1.0.0 - #149
Merged
Merged
Conversation
Contributor
|
I'll fix CI failures and address comments from users with write access. I'll skip comments containing "(aside)".
|
Co-Authored-By: Claude Opus 5.5 (1M context) <noreply@anthropic.com>
ld-paul
force-pushed
the
devin/1792519283-skills-min-version
branch
from
October 29, 2026 19:15
2c9af45 to
7cbff13
Compare
atornsii
approved these changes
Oct 29, 2026
ld-paul
added a commit
to launchdarkly/python-ai-sdk
that referenced
this pull request
Oct 29, 2026
) # Human Agent Skills and Evaluations from Code are both in core now, and both need the 1.0.0 release. This PR says so where people read about each feature. # Bot - `packages/client/README.md`: a "Requires `launchdarkly-ai-server` 1.0.0 or later" callout at the top of the Agent Skills and Run an evaluation from code sections. Each one notes that upgrading `launchdarkly-ai-python` alone can leave an older `launchdarkly-ai-server` installed and gives `pip install --upgrade "launchdarkly-ai-server>=1.0.0"`. - `packages/ai/README.md`: the Agent Skills section already stated 1.0.0. The Evaluations from Code paragraph now states it too. Replaces the earlier version of this PR, which gave a 0.3.0 floor and described Skills as experimental. Docs only. It lands in 1.0.0 if it merges before #231. The JS half is launchdarkly/js-ai-sdk#149. 🤖 Generated with [Claude Code](https://claude.com/claude-code) <!-- CURSOR_SUMMARY --> --- > [!NOTE] > **Overview** > Documentation now consistently states that **Agent Skills** and **Evaluations from Code** require **`launchdarkly-ai-server` 1.0.0 or later**, because those capabilities moved into core at that release. > > In **`packages/client/README.md`**, matching blockquote callouts were added at the start of the **Run an evaluation from code** and **Agent Skills** sections. Each explains that older server versions lack the feature in core, that upgrading **`launchdarkly-ai-python` alone** may leave an outdated **`launchdarkly-ai-server`** installed, and gives **`pip install --upgrade "launchdarkly-ai-server>=1.0.0"`**. > > In **`packages/ai/README.md`**, the Evaluations from Code blurb was aligned with the existing Agent Skills wording by adding the same **1.0.0** dependency note before the evaluations guide link. > > <sup>Reviewed by [Cursor Bugbot](https://cursor.com/bugbot) for commit e0abb76. Bugbot is set up for automated code reviews on this repo. Configure [here](https://www.cursor.com/dashboard/bugbot).</sup> <!-- /CURSOR_SUMMARY --> Co-authored-by: Claude Opus 5.5 (1M context) <noreply@anthropic.com>
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Human
Agent Skills and Evaluations from Code are both in core now, and both need the 1.0.0 release. This PR says so where people read about each feature.
Bot
packages/client/README.md: a "Requires@launchdarkly/ai-server1.0.0 or later (or@launchdarkly/ai-node1.0.0 or later)" callout at the top of the Agent Skills and Evaluations from Code sections.packages/ai-node/README.md: the Agent Skills and Evaluations from Code paragraphs each state the@launchdarkly/ai-node1.0.0 floor.Replaces the earlier version of this PR, which gave 0.4.0 and 0.3.0 floors and described Skills as experimental. Docs only. It lands in 1.0.0 if it merges before #171. The Python half is launchdarkly/python-ai-sdk#191.
🤖 Generated with Claude Code