Skip to content
This repository was archived by the owner on Mar 3, 2026. It is now read-only.
This repository was archived by the owner on Mar 3, 2026. It is now read-only.

Security vulnerability with fast-xml-parser dependency #2709

Closed

Description

@Cha0yue

Searched for a similar issue but only found #2504 which was more than a year ago. It seems like there is another vulnerability affecting fast-xml-parser (GHSA-37qj-frw5-hhjh) versions 4.3.6 to 5.3.4, and @google-cloud/storage appears to depend on fast-xml-parser@4.5.3

Activity

  1. added a commit that references this issue on Feb 1, 2026
    75805ca
  2. lalawow commented on Feb 5, 2026

    @lalawow
  3. lalawow commented on Feb 5, 2026

    @lalawow

    Let's hope this #2694 can be released soon.

  4. vterzic-yokoy commented on Feb 23, 2026

    @vterzic-yokoy

    hi @ddelgrosso1 , it looks there is another security issue with fast-xml-parser GHSA-m7jm-9gc2-mpf2

    I think we need another update 🙏

  5. ddelgrosso1 commented on Feb 25, 2026

    @ddelgrosso1
    Contributor
  6. iurisilvio commented on Feb 26, 2026

    @iurisilvio

    No need for another update, "fast-xml-parser": "^5.3.4" can be updated to a safe version (5.3.5+) without changes here.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

Labels

api: storageIssues related to the googleapis/nodejs-storage API.

Type

No type

Projects

No projects

    Milestone

    No milestone

    Relationships

    None yet

    Development

    No branches or pull requests

    Issue actions