Repository navigation
Require Node.js 24.15 or later for book-app-web - #52
Merged
Merged
Conversation
jsdom 30 (from #47) requires Node.js ^24.15.0 on the 24 line. Update engines.node so npm reports an unsupported Node version clearly, and update the Copilot instructions to match. Co-authored-by: Copilot <223556219+Copilot@users.noreply.github.com>
There was a problem hiding this comment.
🟢 Approval recommended
The three consistent metadata and documentation changes address unsupported early Node 24 versions without changing application behavior.
No open issues 🎉
1 file not reviewed
samples/book-app-web/package-lock.json: Generated file
What changed in this PR
Raises the book-app-web sample’s minimum Node.js version to 24.15.0, matching jsdom 30’s requirement within the Node 24 release line.
Changes:
- Updates the minimum version in the package manifest and lockfile.
- Aligns contributor instructions without changing dependencies or application behavior.
| File | Description |
|---|---|
samples/book-app-web/package.json |
Raises engines.node to >=24.15.0. |
samples/book-app-web/package-lock.json |
Synchronizes the root Node.js requirement. |
.github/copilot-instructions.md |
Documents the updated minimum and its jsdom rationale. |
Review effort: Max
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Why
#47 updated jsdom to 30.1.3. jsdom 30 and some of its dependencies need Node.js
^22.22.2 || ^24.15.0 || >=26.0.0. The sample declaredengines.nodeas>=24.0.0. Node 24.0 through 24.14 is therefore outside the supported range.Changes
engines.nodeto>=24.15.0insamples/book-app-web/package.json.samples/book-app-web/package-lock.json..github/copilot-instructions.md.The course docs already say "current Node.js LTS". CI uses
node-version: "24". Neither needs a change.Validation
Verified at commit
81c759b96ac608d305d5c0ac2b37ce01bfc3eb32, which includes the merged Dependabot updates frommain.npm ci --no-fund --no-auditcompletes with no engine warnings.npm test -- --run: all 4 tests pass.npm run build: the TypeScript check and production build pass.Non-blocking observations
fsevents@2.3.3. Its native module loads and exposeswatch. No script-approval policy was changed./favicon.ico. The sample has no favicon. This existed before this PR. No JavaScript runtime exceptions or other browser warnings/errors were found in the checked flows.