Repository navigation
chore(deps): upgrade cicero-core to 3.1.0 - #211
Merged
Merged
Conversation
cicero-core 3.1.0 also loads templates whose accordproject.cicero range targets ^2.x (accordproject/template-archive#962), so templates written for template-engine 5 keep loading without a range bump. Requiring ^3.1.0 keeps consumers off 3.0.0, which rejects them. Add a test that a template targeting ^2.0.0 loads and inits. Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com> Signed-off-by: Matt Roberts <code@rbrts.uk>
Contributor
There was a problem hiding this comment.
🟢 Approval recommended
The dependency updates are consistent, and the regression test covers the intended compatibility behavior with no blocking issues identified.
No open issues 🎉
What changed in this PR
Raises the cicero-core minimum to 3.1.0 so template-engine v6 can load templates targeting Cicero 2.x without changing their declared range.
Changes:
- Updates the dependency range and locks cicero-core to 3.1.0.
- Adds a regression test for loading and initializing a template targeting
^2.0.0.
| File | Description |
|---|---|
| test/TemplateArchiveProcessor.test.ts | Tests compatibility with a Cicero 2.x template. |
| package.json | Requires cicero-core ^3.1.0. |
| package-lock.json | Resolves cicero-core to 3.1.0. |
Review effort: Balanced
Coverage Report for CI Build 39316338853Coverage remained the same at 73.115%Details
Uncovered ChangesNo uncovered changes found. Coverage RegressionsNo coverage regressions found. Coverage Stats💛 - Coveralls |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Requires
@accordproject/cicero-core^3.1.0instead of^3.0.0.cicero-core 3.1.0 (accordproject/template-archive#962) also loads templates whose
accordproject.cicerorange targets^2.x. Templates written for template-engine 5 therefore keep loading in v6 without a range bump, and their hashes and signatures stay the same. Raising the floor keeps consumers off 3.0.0, which rejects those templates.Changes
package.json/package-lock.json: cicero-core^3.0.0→^3.1.0(resolves to 3.1.0). Markdown (^2.0.0) and concerto-codegen (^7.1.0) are already on their latest releases since chore(deps): upgrade markdown packages to 2.0.0, concerto-codegen to 7.1.0 and cicero-core to 3.0.0 #206, so they don't change.test/TemplateArchiveProcessor.test.ts: new test that copieslatedeliveryandpenalty-typescript, sets its range to^2.0.0, then loads and inits it.Flags
Template#getHash()for templates with more than one model file. Hashes of those templates change, so signatures made with cicero-core ≤ 3.0 on such templates no longer verify. This belongs in the v6 release notes.^3.0.0; the new test covers^2.0.0.Related Issues
Lint (0 errors) and the full jest suite (183 passed) pass locally.
🤖 Generated with Claude Code