Skip to content

cannot access bucket through local network #97

Description

@edwardhuanghz

kubectl describe persistentvolumeclaim/ibmc-s3fs-pvc
Name: ibmc-s3fs-pvc
Namespace: default
StorageClass: ibmc-s3fs-standard
Status: Pending
Volume:
Labels:
Annotations: ibm.io/auto-create-bucket: false
ibm.io/auto-delete-bucket: false
ibm.io/bucket: dolphinscheduler-share
ibm.io/endpoint: http://192.168.0.58:9000
ibm.io/object-path:
ibm.io/region: us-standard
ibm.io/secret-name: minio-secret
ibm.io/stat-cache-expire-seconds:
volume.beta.kubernetes.io/storage-provisioner: ibm.io/ibmc-s3fs
volume.beta.kuenetes.io/storage-class: ibmc-s3fs-standard
Finalizers: [kubernetes.io/pvc-protection]
Capacity:
Access Modes:
VolumeMode: Filesystem
Used By:
Events:
Type Reason Age From Message


Normal Provisioning 30m ibm.io/ibmc-s3fs_ibmcloud-object-storage-plugin-756ccd6c4c-rnl57_72fe74ef-eb8a-4963-ae75-ddee53eaeeb9 External provisioner is provisioning volume for claim "default/ibmc-s3fs-pvc"
Warning ProvisioningFailed 28m ibm.io/ibmc-s3fs_ibmcloud-object-storage-plugin-756ccd6c4c-rnl57_72fe74ef-eb8a-4963-ae75-ddee53eaeeb9 failed to provision volume with StorageClass "ibmc-s3fs-standard": ibmc-s3fs-pvc : dummyClusterID :cannot access bucket dolphinscheduler-share: RequestError: send request failed
caused by: Head "http://192.168.0.58:9000/dolphinscheduler-share": dial tcp 192.168.0.58:9000: i/o timeout
Normal ExternalProvisioning 41s (x123 over 30m) persistentvolume-controller waiting for a volume to be created, either by external provisioner "ibm.io/ibmc-s3fs" or manually created by system administrator

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions