From d8c282ecf7e1eb7355ca212366e9bc5152ce603b Mon Sep 17 00:00:00 2001 From: "dependabot[bot]" <49699333+dependabot[bot]@users.noreply.github.com> Date: Thu, 5 Nov 2026 04:23:13 +0000 Subject: [PATCH] Update cython requirement from <4,>=3.2.6 to >=3.3.1,<4 in /sdks/python Updates the requirements on [cython](https://github.com/cython/cython) to permit the latest version. - [Release notes](https://github.com/cython/cython/releases) - [Changelog](https://github.com/cython/cython/blob/master/CHANGES.rst) - [Commits](https://github.com/cython/cython/compare/3.2.6...3.3.1) --- updated-dependencies: - dependency-name: cython dependency-version: 3.3.1 dependency-type: direct:development ... Signed-off-by: dependabot[bot] --- sdks/python/pyproject.toml | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/sdks/python/pyproject.toml b/sdks/python/pyproject.toml index b3fe73f4697d..4a2fa4c328a5 100644 --- a/sdks/python/pyproject.toml +++ b/sdks/python/pyproject.toml @@ -34,7 +34,7 @@ requires = [ "numpy>=1.23.2,<2.6.0; python_version >= '3.12'", # Update setup.py as well. "numpy>=1.23.2,<2.5.0; python_version < '3.12'", # having cython here will create wheels that are platform dependent. - "cython>=3.2.6,<4", + "cython>=3.3.1,<4", ## deps for generating external transform wrappers: # also update PyYaml bounds in sdks:python:generateExternalTransformsConfig 'pyyaml>=3.12,<7.0.0',